因为不能上传超过200K的文件现在图通过附件的形式发送到博客中下面是无路由实现全网互通的实例。
 
 
R1:
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Serial1/0
 ip address 12.1.1.1 255.255.255.0
 ip policy route-map cisco
 serial restart-delay 0
 clock rate 64000
!
interface Serial1/2
 ip address 17.1.1.1 255.255.255.0
 serial restart-delay 0
 clock rate 64000
!
ip local policy route-map cisco
ip classless
no ip http server
!
!
ip access-list extended cisco
 permit ip host 1.1.1.1 host 3.3.3.3
route-map cisco permit 10
 match ip address cisco
 set ip default next-hop 12.1.1.2
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
end
 
 

R2:
interface Serial1/0
 ip address 12.1.1.2 255.255.255.0
 ip policy route-map cisco
 serial restart-delay 0
!
interface Serial1/1
 ip address 23.1.1.2 255.255.255.0
 serial restart-delay 0
!
ip local policy route-map cisco
ip classless
no ip http server
!
!
ip access-list extended cisco
 permit ip host 1.1.1.1 host 3.3.3.3
route-map cisco permit 10
 match ip address cisco
 set ip default next-hop 23.1.1.3
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
end
 
 
R3:
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
!
interface Serial1/1
 ip address 23.1.1.3 255.255.255.0
 serial restart-delay 0
!
interface Serial1/2
 ip address 37.1.1.3 255.255.255.0
 ip policy route-map cisco
 serial restart-delay 0
!       
ip local policy route-map cisco
ip classless
ip http server
!
!
ip access-list extended cisco
 permit ip host 3.3.3.3 host 1.1.1.1
route-map cisco permit 10
 match ip address cisco
 set ip default next-hop 37.1.1.7
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
end
 
R7:
interface Serial1/0
 ip address 17.1.1.7 255.255.255.0
 serial restart-delay 0
!
interface Serial1/2
 ip address 37.1.1.7 255.255.255.0
 ip policy route-map cisco
 serial restart-delay 0
!      
ip local policy route-map cisco
no ip http server
no ip http secure-server
!
!
!
ip access-list extended cisco
 permit ip host 3.3.3.3 host 1.1.1.1
!
logging alarm informational
!
!
!
route-map cisco permit 10
 match ip address cisco
 set ip default next-hop 17.1.1.1
!
!
!
!
control-plane
!
!        
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
!
!
end