当前位置: 首页 > news >正文

poj2420 A Star not a Tree?

A Star not a Tree?
http://poj.org/problem?id=2420
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7684 Accepted: 3502

Description

Luke wants to upgrade his home computer network from 10mbs to 100mbs. His existing network uses 10base2 (coaxial) cables that allow you to connect any number of computers together in a linear arrangement. Luke is particulary proud that he solved a nasty NP-complete problem in order to minimize the total cable length. 
Unfortunately, Luke cannot use his existing cabling. The 100mbs system uses 100baseT (twisted pair) cables. Each 100baseT cable connects only two devices: either two network cards or a network card and a hub. (A hub is an electronic device that interconnects several cables.) Luke has a choice: He can buy 2N-2 network cards and connect his N computers together by inserting one or more cards into each computer and connecting them all together. Or he can buy N network cards and a hub and connect each of his N computers to the hub. The first approach would require that Luke configure his operating system to forward network traffic. However, with the installation of Winux 2007.2, Luke discovered that network forwarding no longer worked. He couldn't figure out how to re-enable forwarding, and he had never heard of Prim or Kruskal, so he settled on the second approach: N network cards and a hub. 

Luke lives in a loft and so is prepared to run the cables and place the hub anywhere. But he won't move his computers. He wants to minimize the total length of cable he must buy.

Input

The first line of input contains a positive integer N <= 100, the number of computers. N lines follow; each gives the (x,y) coordinates (in mm.) of a computer within the room. All coordinates are integers between 0 and 10,000.

Output

Output consists of one number, the total length of the cable segments, rounded to the nearest mm.

Sample Input

4
0 0
0 10000
10000 10000
10000 0

Sample Output

28284

题意: 求平面上一点,到其它点的距离最小
模拟退火第一题
#include<cstdio>
#include<cmath>
#define N 101

#define eps 1e-8
#define delta 0.98
#define T 100
#define INF 1e20;

using namespace std;

int dx[4]={-1,0,1,0};
int dy[4]={0,1,0,-1};
int n;

struct Point
{
    double x,y;
};
Point p[N];

double dist(Point A,Point B)
{
    return sqrt((A.x-B.x)*(A.x-B.x)+(A.y-B.y)*(A.y-B.y));
}

double getsum(Point z)
{
    double ans=0;
    for(int i=1;i<=n;i++) ans+=dist(p[i],z);
    return ans;
}

double search()
{
    Point s=p[1];
    double t=T;
    double ans=INF;
    while(t>eps)
    {
        bool flag=true;
        while(flag)
        {
            flag=false;
            for(int i=0;i<4;i++)
            {
                Point z;
                z.x=s.x+dx[i]*t;
                z.y=s.y+dy[i]*t;
                double tp=getsum(z);
                if(ans>tp)
                {
                    ans=tp;
                    s=z;
                    flag=true;
                }
            }
        }
        t*=delta;
    }
    return ans;
}

int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++) scanf("%lf%lf",&p[i].x,&p[i].y);
    printf("%.0lf",search());
}

 

转载于:https://www.cnblogs.com/TheRoadToTheGold/p/7636550.html

相关文章:

  • 数据结构(一)
  • C++类对应的内存结构
  • PM2 常用命令
  • 文因互联CEO鲍捷:做聊天机器人有哪些坑?
  • 使用Flash打造可定义界面风格的文件上传控件
  • go 入门学习笔记之 select + chan (十一)
  • HTML5 history API实践
  • 项目中使用RDLC报表
  • Workflow笔记2——状态机工作流
  • Octoroit OS VB操作系统简单介绍
  • 【C#】与C及OC的不同点
  • 10个小技巧帮助Devops走向成功
  • [UVA 11825] Hackers' Crackdown
  • Springboot集成Mybatis
  • 11.32 php扩展模块安装
  • centos安装java运行环境jdk+tomcat
  • CSS魔法堂:Absolute Positioning就这个样
  •  D - 粉碎叛乱F - 其他起义
  • IE报vuex requires a Promise polyfill in this browser问题解决
  • leetcode讲解--894. All Possible Full Binary Trees
  • Linux学习笔记6-使用fdisk进行磁盘管理
  • log4j2输出到kafka
  • markdown编辑器简评
  • SpringCloud集成分布式事务LCN (一)
  • WebSocket使用
  • 百度地图API标注+时间轴组件
  • 半理解系列--Promise的进化史
  • 分享一份非常强势的Android面试题
  • 后端_ThinkPHP5
  • 欢迎参加第二届中国游戏开发者大会
  • 开放才能进步!Angular和Wijmo一起走过的日子
  • 利用jquery编写加法运算验证码
  • 微信小程序:实现悬浮返回和分享按钮
  • 一文看透浏览器架构
  • 怎样选择前端框架
  • #我与Java虚拟机的故事#连载15:完整阅读的第一本技术书籍
  • (9)YOLO-Pose:使用对象关键点相似性损失增强多人姿态估计的增强版YOLO
  • (ctrl.obj) : error LNK2038: 检测到“RuntimeLibrary”的不匹配项: 值“MDd_DynamicDebug”不匹配值“
  • (HAL)STM32F103C6T8——软件模拟I2C驱动0.96寸OLED屏幕
  • (二十一)devops持续集成开发——使用jenkins的Docker Pipeline插件完成docker项目的pipeline流水线发布
  • (附源码)springboot“微印象”在线打印预约系统 毕业设计 061642
  • (附源码)springboot高校宿舍交电费系统 毕业设计031552
  • (附源码)ssm智慧社区管理系统 毕业设计 101635
  • (六)c52学习之旅-独立按键
  • (转载)利用webkit抓取动态网页和链接
  • .mat 文件的加载与创建 矩阵变图像? ∈ Matlab 使用笔记
  • .NET 8 中引入新的 IHostedLifecycleService 接口 实现定时任务
  • .NET Core 和 .NET Framework 中的 MEF2
  • .Net 访问电子邮箱-LumiSoft.Net,好用
  • .NET 将混合了多个不同平台(Windows Mac Linux)的文件 目录的路径格式化成同一个平台下的路径
  • .net 重复调用webservice_Java RMI 远程调用详解,优劣势说明
  • .net 桌面开发 运行一阵子就自动关闭_聊城旋转门家用价格大约是多少,全自动旋转门,期待合作...
  • .NET/C# 利用 Walterlv.WeakEvents 高性能地定义和使用弱事件
  • .NET企业级应用架构设计系列之技术选型
  • ?php echo ?,?php echo Hello world!;?