当前位置: 首页 > news >正文

C - Train Problem II——(HDU 1023 Catalan 数)

传送门

Train Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7616    Accepted Submission(s): 4101


Problem Description
As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.
 

Input
The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.
 

Output
For each test case, you should output how many ways that all the trains can get out of the railway.
 

Sample Input
 
  
1 2 3 10
 

Sample Output
 
  
1 2 5 16796
Hint
The result will be very large, so you may not process it by 32-bit integers.

 
题目大意:

就是求一个卡特兰数,如果是C++的话 得用高精度,java 的话 得用 BigInteger。。。


解题思路:

只要掌握卡特兰数的公式就行了,两个公式:

1. 组合公式为 Cn = C(2n,n) / (n+1);
2. 递推公式为 h(n ) = h(n-1)*(4*n-2) / (n+1)

我们采用的是第二个,如果用java 写的话还是比较省事儿的,因为直接有个大数类,所以直接调用就行,所以我也先给一个java的代码(也是第一次写java代码 有点小紧张):

My Java Code:

<span style="font-size:18px;">import java.util.*;
import java.math.BigInteger;
public class Main {
    public static void main(String[] args) {
        BigInteger a[] = new BigInteger[105];
        a[0] = BigInteger.ZERO;
        a[1] = BigInteger.ONE;
        for(int i=2;i<=102;i++) {
            a[i] = a[i-1].multiply(BigInteger.valueOf(4*i-2)).divide(BigInteger.valueOf(i+1));
        }
        
        Scanner in = new Scanner(System.in);
        
        while(in.hasNext()) {
            int n=in.nextInt();
            System.out.println(a[n]);
        }
    }
}</span>

然后接下来就是用c++写的了,这个得用到 高精度乘法,然后采用了bin神的Catalan数模板,觉得还是比较实用的,自己也做了一点小改动,当然适合自己的才是最好的,只要理解起来容易,怎么理解方便怎么来,给一下AC 的C++代码:

My Cpp Code:

<span style="font-size:18px;">#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int MAXN = 105;
int a[MAXN][MAXN];
int b[MAXN];
///可以作为模板
void Catalan()
{
    int yu,len;
    a[1][0] = 1;
    a[1][1] = 1;
    len = 1;
    for(int i=2; i<MAXN; i++)
    {
        yu = 0;
        for(int j=1; j<=len; j++)
        {
            int t = (a[i-1][j])*(4*i-2) + yu;
            yu = t/10;
            a[i][j] = t%10;
        }
        while(yu)
        {
            a[i][++len] = yu%10;
            yu /= 10;
        }
        for(int j=len; j>=1; j--)
        {
            int t = a[i][j]+yu*10;
            a[i][j] = t/(i+1);
            yu = t%(i+1);
        }
        while(!a[i][len])
            len--;
        a[i][0] = len;
    }
}
int main()
{
    Catalan();
    int n;
    while(cin>>n)
    {
        for(int i=a[n][0]; i>0; i--)
        cout<<a[n][i];
        puts("");
    }
    return 0;
}
</span>






相关文章:

  • 每周总结和进度报告
  • windows中:git 使用RBTools工具 review
  • 获取Ceph的CRUSH Map和CRUSH Map介绍
  • 微信支付v3开发(5) 扫码并输入金额支付
  • 教你如何获取索爱X10 Android2.1 Root权限
  • Perl语言——简单说明
  • Linux命令(4):cat命令
  • javascript 闭包理解例子
  • 客户端putty, xshell连接linux中vim的小键盘问题
  • 2016蘑菇街编程题5题
  • C指针(二)
  • 用Python开发自动化测试脚本
  • git简单命令
  • 程序员健康Tips
  • 如何从mysql备份中提取单张表数据
  • Android Volley源码解析
  • electron原来这么简单----打包你的react、VUE桌面应用程序
  • JavaSE小实践1:Java爬取斗图网站的所有表情包
  • JS实现简单的MVC模式开发小游戏
  • Laravel Telescope:优雅的应用调试工具
  • Linux中的硬链接与软链接
  • Traffic-Sign Detection and Classification in the Wild 论文笔记
  • 服务器从安装到部署全过程(二)
  • 简析gRPC client 连接管理
  • 聊聊flink的TableFactory
  • 前端学习笔记之观察者模式
  • 白色的风信子
  • 通过调用文摘列表API获取文摘
  • ​油烟净化器电源安全,保障健康餐饮生活
  • # 飞书APP集成平台-数字化落地
  • #AngularJS#$sce.trustAsResourceUrl
  • #QT(TCP网络编程-服务端)
  • $ git push -u origin master 推送到远程库出错
  • (Redis使用系列) SpringBoot 中对应2.0.x版本的Redis配置 一
  • (更新)A股上市公司华证ESG评级得分稳健性校验ESG得分年均值中位数(2009-2023年.12)
  • (亲测有效)解决windows11无法使用1500000波特率的问题
  • (数位dp) 算法竞赛入门到进阶 书本题集
  • (未解决)jmeter报错之“请在微信客户端打开链接”
  • .Net 6.0 处理跨域的方式
  • .net core IResultFilter 的 OnResultExecuted和OnResultExecuting的区别
  • .NET Core/Framework 创建委托以大幅度提高反射调用的性能
  • .NET Micro Framework初体验
  • .NET/C# 使用 ConditionalWeakTable 附加字段(CLR 版本的附加属性,也可用用来当作弱引用字典 WeakDictionary)
  • .NET/C# 使用反射调用含 ref 或 out 参数的方法
  • .NET文档生成工具ADB使用图文教程
  • .net专家(高海东的专栏)
  • /usr/local/nginx/logs/nginx.pid failed (2: No such file or directory)
  • @Autowired自动装配
  • @ConditionalOnProperty注解使用说明
  • [ 手记 ] 关于tomcat开机启动设置问题
  • [8-23]知识梳理:文件系统、Bash基础特性、目录管理、文件管理、文本查看编辑处理...
  • [ai笔记4] 将AI工具场景化,应用于生活和工作
  • [AX]AX2012 AIF(四):文档服务应用实例
  • [BZOJ 3680]吊打XXX(模拟退火)
  • [BZOJ] 2427: [HAOI2010]软件安装