当前位置: 首页 > news >正文

VPC配置案例

拓扑:
VPC配置案例
配置:
N9K-1:

vlan 1-500

vrf context APP
vrf context CTRIX
vrf context DB
vrf context Keep_alive
vrf context VM
vrf context management
vpc domain 1000
peer-switch
role priority 65535
peer-keepalive destination 172.16.1.2 source 172.16.1.1 vrf Keep_alive
auto-recovery

interface Vlan1

interface Vlan10
no shutdown
vrf member VM
ip address 10.10.1.251/24
hsrp 10
ip 10.10.1.254
hsrp 20
preempt
priority 110

interface Vlan20
no shutdown
vrf member VM
ip address 10.10.2.251/24
hsrp 20
preempt
priority 110
ip 10.10.2.254

interface Vlan30
no shutdown
vrf member APP
ip address 10.10.3.251/24
hsrp 30
preempt
priority 110
ip 10.10.3.254

interface Vlan40
no shutdown
vrf member APP
ip address 10.10.4.251/24
hsrp 40
preempt
priority 110
ip 10.10.4.254

interface Vlan50
no shutdown
vrf member CTRIX
ip address 10.10.5.251/24
hsrp 50
preempt
priority 110
ip 10.10.5.254

interface Vlan60
no shutdown
vrf member CTRIX
ip address 10.10.6.251/24
hsrp 60
preempt
priority 110
ip 10.10.6.254

interface Vlan70
no shutdown
vrf member DB
ip address 10.10.7.251/24
hsrp 70
preempt
priority 110
ip 10.10.7.254

interface Vlan80
no shutdown
vrf member DB
ip address 10.10.8.251/24
hsrp 80
preempt
priority 110
ip 10.10.8.254

interface port-channel10
no switchport
vrf member Keep_alive
ip address 172.16.1.1/30

interface port-channel20
switchport mode trunk
spanning-tree port type network
vpc peer-link

interface port-channel30
switchport mode trunk
vpc 101

interface Ethernet1/1
no switchport
channel-group 10 mode active
no shutdown

interface Ethernet1/2
no switchport
channel-group 10 mode active
no shutdown

interface Ethernet1/3
switchport mode trunk
channel-group 20 mode active

interface Ethernet1/4
switchport mode trunk
channel-group 20 mode active

interface Ethernet1/5
switchport mode trunk
channel-group 30 mode active
N9K-2:

cfs eth distribute
feature interface-vlan
feature hsrp
feature lacp
feature vpc

vlan 1-500

vrf context APP
vrf context CTRIX
vrf context DB
vrf context Keep_alive
vrf context VM
vrf context management
vpc domain 1000
peer-switch
peer-keepalive destination 172.16.1.1 source 172.16.1.2 vrf Keep_alive
auto-recovery

interface Vlan1

interface Vlan10
no shutdown
vrf member VM
ip address 10.10.1.252/24
hsrp 10
ip 10.10.1.254

interface Vlan20
no shutdown
vrf member VM
ip address 10.10.2.252/24
hsrp 20
ip 10.10.2.254

interface Vlan30
no shutdown
vrf member APP
ip address 10.10.3.252/24
hsrp 30
ip 10.10.3.254

interface Vlan40
no shutdown
vrf member APP
ip address 10.10.4.252/24
hsrp 40
ip 10.10.4.254

interface Vlan50
no shutdown
vrf member CTRIX
ip address 10.10.5.252/24
hsrp 50
ip 10.10.5.254

interface Vlan60
no shutdown
vrf member CTRIX
ip address 10.10.6.252/24
hsrp 60
ip 10.10.6.254

interface Vlan70
no shutdown
vrf member DB
ip address 10.10.7.252/24
hsrp 70
ip 10.10.7.254

interface Vlan80
no shutdown
vrf member DB
ip address 10.10.8.252/24
hsrp 80
ip 10.10.8.254

interface port-channel10
no switchport
vrf member Keep_alive
ip address 172.16.1.2/30

interface port-channel20
switchport mode trunk
spanning-tree port type network
vpc peer-link

interface port-channel30
switchport mode trunk
vpc 101

interface Ethernet1/1
no switchport
channel-group 10 mode active
no shutdown

interface Ethernet1/2
no switchport
channel-group 10 mode active
no shutdown

interface Ethernet1/3
switchport mode trunk
channel-group 20 mode active

interface Ethernet1/4
switchport mode trunk
channel-group 20 mode active

interface Ethernet1/5
switchport mode trunk
channel-group 30 mode active
N5K:
vlan 1-500

vrf context management

interface port-channel30
switchport mode trunk

interface Ethernet1/1
switchport mode trunk
channel-group 30 mode active

interface Ethernet1/2
switchport mode trunk
channel-group 30 mode active
在N9K上查看VPC状态如下:
VPC配置案例
要点总结:
(1)keep_alive最好一个vrf,并且最好一个做链路聚合
(2)最好配置auto-recovery和peer-switch

转载于:https://blog.51cto.com/shenzhenvc/2311614

相关文章:

  • 使用CefSharp的一些需要注意的点
  • Kibana配置logstash,报表一体化
  • 读程序员,你焦虑吗有感。
  • 利用github和git命令,将本地项目共享到服务器上——第二章
  • SQL/My sql
  • 微信小程序点击图片放大预览
  • activit5升到flowable后的全局设置的修改
  • Facebook智能bug修复神器:让程序员少掉几根头发
  • Android-来填写一个验证码吧!(二)
  • webpack的使用
  • 最详细的Log4j使用教程
  • Javascript 对象 - 数学对象
  • 浅析微信支付:申请退款、退款回调接口、查询退款
  • 都是用 DllImport?有没有考虑过自己写一个 extern 方法?
  • python实现将json数据以json格式写入txt文件
  • angular2开源库收集
  • ES10 特性的完整指南
  • Facebook AccountKit 接入的坑点
  • FastReport在线报表设计器工作原理
  • javascript 哈希表
  • Javascript基础之Array数组API
  • JDK9: 集成 Jshell 和 Maven 项目.
  • 对象管理器(defineProperty)学习笔记
  • 关键词挖掘技术哪家强(一)基于node.js技术开发一个关键字查询工具
  • 回顾 Swift 多平台移植进度 #2
  • 每天一个设计模式之命令模式
  • 前端技术周刊 2018-12-10:前端自动化测试
  • 它承受着该等级不该有的简单, leetcode 564 寻找最近的回文数
  • 微服务核心架构梳理
  • 终端用户监控:真实用户监控还是模拟监控?
  • HanLP分词命名实体提取详解
  • ​ssh免密码登录设置及问题总结
  • # 睡眠3秒_床上这样睡觉的人,睡眠质量多半不好
  • #我与Java虚拟机的故事#连载17:我的Java技术水平有了一个本质的提升
  • (C语言)共用体union的用法举例
  • (env: Windows,mp,1.06.2308310; lib: 3.2.4) uniapp微信小程序
  • (floyd+补集) poj 3275
  • (LeetCode) T14. Longest Common Prefix
  • (层次遍历)104. 二叉树的最大深度
  • (附源码)springboot高校宿舍交电费系统 毕业设计031552
  • (六)c52学习之旅-独立按键
  • (算法)前K大的和
  • (一)spring cloud微服务分布式云架构 - Spring Cloud简介
  • (转)setTimeout 和 setInterval 的区别
  • . Flume面试题
  • .apk 成为历史!
  • .NET 8.0 中有哪些新的变化?
  • .NET Core 2.1路线图
  • .net framework 4.0中如何 输出 form 的name属性。
  • .Net Framework 4.x 程序到底运行在哪个 CLR 版本之上
  • .net web项目 调用webService
  • .Net Winform开发笔记(一)
  • .NET 中 GetHashCode 的哈希值有多大概率会相同(哈希碰撞)
  • .net开发引用程序集提示没有强名称的解决办法
  • .project文件